Проблема

При попытке Выполнить отгрузку товаров из магазина в магазин в документе Перемещение товаров летит ошибка “Превышен свободный остаток на складе X на Y”. Настройка Прав пользователя или Дополнительных прав не влияет на это ограничение, т.к. это новая отдельная независимая обработка введенная с версии 2.2.6.

Решение

Самый простой вариант исправить ситуацию – идём в Конфигуратор, открываем конфигурацию, через Глобальный поиск (Ctrl + Shift + F) и ищем фразу “Превышен свободный остаток”.

Попадаем в: Основная конфигурация Обработка.ПомощникПриемкиОтгрузки.Форма.Форма.Форма.Модуль(4186, 36)

Видим кусок кода:

Для Инд = 0 По СтруктураПроверки.МассивКоличествКПеремещению.ВГраница() Цикл
Если не СтруктураПроверки.МассивКоличествКПеремещению[Инд] = 0 и СтруктураПроверки.МассивКоличествКПеремещению[Инд] > СтруктураПроверки.МассивКоличествОстаток[Инд] Тогда
РезультатПроверки = Ложь;
ТекущееСообщение = НСтр(“ru = ‘Превышен свободный остаток на складе %1 на %2 %3′”);
ТекущееСообщение = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекущееСообщение, СтруктураПроверки.МассивСкладов[Инд], СтруктураПроверки.МассивКоличествКПеремещению[Инд] – СтруктураПроверки.МассивКоличествОстаток[Инд], СтруктураПроверки.ЕдиницаИзмерения);
МассивСообщений.Добавить(ТекущееСообщение);
КонецЕсли;
КонецЦикла;

Меняем на:

Для Инд = 0 По СтруктураПроверки.МассивКоличествКПеремещению.ВГраница() Цикл
Если не СтруктураПроверки.МассивКоличествКПеремещению[Инд] = 0 и СтруктураПроверки.МассивКоличествКПеремещению[Инд] > СтруктураПроверки.МассивКоличествОстаток[Инд] Тогда
//Разрешение отгрузки с минусовым количеством на складе НАЧАЛО ИЗМЕНЕНИЕ
//РезультатПроверки = Ложь;
РезультатПроверки = Истина;
//Разрешение отгрузки с минусовым количеством на складе КОНЕЦ
ТекущееСообщение = НСтр(“ru = ‘Превышен свободный остаток на складе %1 на %2 %3′”);
ТекущееСообщение = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекущееСообщение, СтруктураПроверки.МассивСкладов[Инд], СтруктураПроверки.МассивКоличествКПеремещению[Инд] – СтруктураПроверки.МассивКоличествОстаток[Инд], СтруктураПроверки.ЕдиницаИзмерения);
МассивСообщений.Добавить(ТекущееСообщение);
КонецЕсли;
КонецЦикла;

Сохраняем, обновляем конфигурацию БД и проверяем. Отгрузка происходит, движения формируются.

Надеюсь Вам было полезно 🙂

Поделиться